Probleme bei der Migration von Formularen von OpenOffice Windows auf LibreOffice unter Linux Mint

Base ermöglicht es Ihnen, Ihre Daten in einer Datenbank direkt mit LibreOffice zu bearbeiten.
Antworten
lagasch
Beiträge: 2
Registriert: Di 12. Feb 2019, 20:43

Probleme bei der Migration von Formularen von OpenOffice Windows auf LibreOffice unter Linux Mint

Beitrag von lagasch » Di 12. Feb 2019, 21:22

Hallo alle
Vielleicht kennt jemand von euch die Probleme, die entstehen, wenn man Formulare von Windows auf Linux und in eine neue Office-Version (oder eigentlich in ein anderes Office) migriert?
Klar ist, dass die Pfadangaben geändert werden müssen (geht recht einfach mit Suchen und Ersetzen).
Offenbar hat LibreOffice das Handling der Datumsvariablen verbessert; darüber bin ich gar nicht traurig, auch wenn ich einige Zeit brauchte, um die Fehler (die früheren Umwege) im alten Code nachzubessern.
Was ich aber nicht verstehe: Ich habe in meinen Formularen jeweils eine Leiste, um in den Datensätzen zu navigieren, aber die Schaltfläche zum Löschen eines Datensatzes ist ausser Funktion. Das heisst ich kann überhaupt keinen Datensatz mehr löschen, was in der früheren Version problemlos ging. Ich habe alles überprüft und festgestellt, dass die entsprechenden Berechtigungen eigentlich bestehen. Was hat sich da geändert? Ich musste ins Datenbankfile, dort die Tabelle laden und den Datensatz über den Menueeintrag löschen (die Deletetaste funktioniert auch dort nicht).
Ich verwende Maria.DB auf einem NAS-Server als Datenquelle und verbinde über den Mysql-Connector von LibreOffice.
Es sind relativ komplexe Formulare mit vielen Makros, aber dieses Verhalten erscheint mir eine basale Sache und unerklärlich.
Falls jemand das gleiche Problem hat (hatte), könnte er / sie mir vielleicht helfen.
Vielen Dank

RobertG
Beiträge: 1932
Registriert: Sa 19. Mai 2012, 17:37
Kontaktdaten:

Re: Probleme bei der Migration von Formularen von OpenOffice Windows auf LibreOffice unter Linux Mint

Beitrag von RobertG » Mi 13. Feb 2019, 16:24

Hallo Lagagsch,

ist bei Dir die Löschtaste auf der eingebauten Navigationsleiste inaktiv? Dann dürfte das ein Problem mit der MySQL-Verbindung. Das Löschen unter LO 6.1.5.2 mit den Funktionen in der Navigationsleiste macht bei mir bei der internen Datenbank keine Probleme (OpenSUSE 15, 64bit rpm Linux).

Du arbeitest mit der direkten Verbindung? Da kann ich Dir nicht weiter helfen, weil die bei mir nur eingeschränkt funktioniert. Ich erhalte keinen Schreibzugriff mit der direkten Verbindung über LO 6.2. Für die Vorgängerversion 6.1 funktioniert die Extension von LO hier nicht. Deshalb rate ich allen Leuten, die JDBC-Verbindung zu nutzen.

Gruß

Robert

lagasch
Beiträge: 2
Registriert: Di 12. Feb 2019, 20:43

Re: Probleme bei der Migration von Formularen von OpenOffice Windows auf LibreOffice unter Linux Mint

Beitrag von lagasch » Mi 13. Feb 2019, 20:59

Vielen Dank, Robert, für deine Antwort.

Am LO Mysql Connector liegt dies wohl eher nicht, da ich ja aus dem Base-File direkt die Daten uneingeschränkt bearbeiten (und auch Datensätze löschen) kann. Oder bedeutet das gar nichts? Die Verbindung ist doch eigentlich dieselbe.
Ich habe die LO Version 6.0.7.3.
Vielleicht probiere ich es auch mit JDBC. Dies habe ich aber mit OO nie hinbekommen. Und ich fürchte, dass ich dann noch mehr Anpassungen vornehmen muss.

Gruss

Lagasch

RobertG
Beiträge: 1932
Registriert: Sa 19. Mai 2012, 17:37
Kontaktdaten:

Re: Probleme bei der Migration von Formularen von OpenOffice Windows auf LibreOffice unter Linux Mint

Beitrag von RobertG » Do 14. Feb 2019, 07:48

Hallo Lagasch,

Du kannst also in einer Tabelle problemlos Daten löschen, nicht nur über Extras > SQL? Dann funktioniert bei Dir der Treiber und ein Wechsel zu JDBC macht keinen Sinn.

Nachvollziehen kann ich das Verhalten mit der fehlenden Löschfunktion trotzdem nicht. Da würde ich dann gegebenenfalls einmal die Ausführung von Makros unterbinden um zu sehen, ob da irgendetwas schief läuft.

Gruß

Robert

Antworten