[gelöst] Mac – El Capitan – Java -> Hilfe !!!

Alles zur Programmierung im LibreOffice.
Antworten
Thymin
Beiträge: 6
Registriert: Mo 19. Okt 2015, 10:37

[gelöst] Mac – El Capitan – Java -> Hilfe !!!

Beitrag von Thymin » Mo 19. Okt 2015, 10:42

Ich weiß dass ich hier in Programmierung bin, aber mein Problem bezieht sich auf die Ausführung von Makros für die Java erforderlich ist !
Nach dem Update von Yosemite (10.10) auf El Capitan (10.11) bekomme ich Java innerhalb von Libreoffice 4.4.5-2 (64bit) nicht mehr zum laufen !
Als Update von Oracle wird nur die Version 1.8 angeboten (64bit) die mit Libreoffice nicht funktioniert.
Eine Installation von Java 1.6 gem.
https://support.apple.com/kb/DL1572?loc ... cale=de_DE
läuft zwar durch, aber die 1.6 ist innerhalb von Libreoffice nicht einbindbar/sichtbar.

Eine Aktivierung gem. Apple-Beschreibung läuft im letztem Schritt nicht durch :evil:

Weiß jemand Rat/Abhilfe ?
Zuletzt geändert von Thymin am Di 20. Okt 2015, 23:59, insgesamt 1-mal geändert.

Thymin
Beiträge: 6
Registriert: Mo 19. Okt 2015, 10:37

Re: Mac – El Capitan – Java -> Hilfe !!!

Beitrag von Thymin » Mo 19. Okt 2015, 11:18

Genau ... Makros in Base :!:

gogo
Beiträge: 857
Registriert: Sa 5. Feb 2011, 19:07

Re: Mac – El Capitan – Java -> Hilfe !!!

Beitrag von gogo » Di 20. Okt 2015, 09:02

- Wenn ich richtig informiert bin, funktionieren die 5.x Versionen auch mit 64-bit Javas.

- Java muss nicht immer "aktiviert" werden um zu laufen, (aber schon damit das System weiss welche Javas alle verfügbar sind ...)

- Ansonsten würd ich mal das LO-Benutzerverzeichnis umbenennen (https://wiki.documentfoundation.org/UserProfile/de), vielleicht wird dann die neue Java-Version ja erkannt
g
2008 LucidL./MaverickM./WinXP LibreOffice 3.3.2 > 02/13 LinuxMint13/Xubuntu > 09/13 Debian Wheezy+LO3.5.4.2 > 01/15 Debian Jessie KDE+LO4.3.3.2/Mint17 openbox auf USB+LO4.2.8.2 > 03/16 ArchLin & LO5.1+ff > 02/18 Kubuntu

Thymin
Beiträge: 6
Registriert: Mo 19. Okt 2015, 10:37

Re: Mac – El Capitan – Java -> Hilfe !!!

Beitrag von Thymin » Di 20. Okt 2015, 13:24

@ gogo: danke Dir, hatte versucht ...hat nichts gebracht.

Hab jetzt weiter geforscht und so wie es sich herausstellt ist Java in der Version 1.6
zumindest für AOO erforderlich, also gehe ich davon aus, ebenfalls für LO.

https://bz.apache.org/ooo/show_bug.cgi?id=126130#c20
Apache OpenOffice (AOO) Bugzilla – Issue 126130

Für mich gibt es momentan zwei Wege:
1. Ich bekomme es hin die das „Apple-Java 1.6“ installiert
(was bis jetzt unter El Capitan nicht klappen wollte)
2. ich führe ein Downgrade von El Capitan (10.11) auf Yosemite (10.10) durch

… und an alle Apple User… „Denn sie wissen, was sie tun“ :roll:
Ihr könnt berichten ;)

Thymin
Beiträge: 6
Registriert: Mo 19. Okt 2015, 10:37

Re: Mac – El Capitan – Java -> Hilfe !!!

Beitrag von Thymin » Di 20. Okt 2015, 23:58

:mrgreen: ich bin weiter !!!
LO benötigt unter OSX definitiv die 1.6 Java Version.
Das neue Update der 1.6 Version "Java for OSX 2015-001" wird von LO nicht erkannt !!!

Die Version "Java for OSX 2014-001" (1.6.0_65) wird erkannt und funktioniert.
https://support.apple.com/kb/DL1829?locale=de_DE

Diese kann parallel zu der 64bit Java Ver. 1.8.0_60 von Oracel installiert werden.

tomas
Beiträge: 18
Registriert: Do 10. Apr 2014, 17:41

Re: [gelöst] Mac – El Capitan – Java -> Hilfe !!!

Beitrag von tomas » So 6. Mär 2016, 10:14

Ich öffne den Thread nochmal:

Ich habe auch Probleme mit LibreOffice 5 und Java.
Ich habe nun nach deinem Post "JavaforOSX" bei Apple runtergeladen und installiert. In der Java-Systemeinstellung wird die 1.6-Version nun aber trotzdem nicht angezeigt. Auch Libreoffice findet die JRE nicht.
Ich habe ja bei LibreOffice die Möglichkeit einen Ordner der JavaVM manuell anzugeben. Welchen Ordner muss ich dort auswählen?

tomas
Beiträge: 18
Registriert: Do 10. Apr 2014, 17:41

Re: [gelöst] Mac – El Capitan – Java -> Hilfe !!!

Beitrag von tomas » Fr 18. Mär 2016, 16:03

Hat keiner einer Idee? :(

Bin leider auf Zotero angewiesen...

tomas
Beiträge: 18
Registriert: Do 10. Apr 2014, 17:41

Re: [gelöst] Mac – El Capitan – Java -> Hilfe !!!

Beitrag von tomas » So 20. Mär 2016, 19:44

Falls noch jemand das Problem hat:
Es muss das JDK nicht das JRE installiert werden:
http://www.oracle.com/technetwork/java/ ... 33151.html

Dann funktioniert auch wieder die Installation vom Zotero-Plugin!

Antworten