ODBCDriver-Problem

Installation / Betrieb / Probleme unter Mac OS
Antworten
ruebezahl
Beiträge: 3
Registriert: Di 2. Dez 2014, 16:49

ODBCDriver-Problem

Beitrag von ruebezahl » Mo 23. Mär 2015, 17:30

Auf meinem iMac mit Betriebssystem OS X 10.10.2 und LibreOffice 4.3.6.2 läuft eine von mir eingerichtete eingebettete Datenbank HSQLDB einwandfrei.

Nachdem ich die Datei dieser Datenbank auf ein MacBook Pro mit Betriebssystem OS X 10.10.2 und neu installiertem LibreOffice 4.3.6.2 kopiert habe, öffnet zwar die Eingangsseite der Datenbank unproblematisch, beim Klicken auf ein Formular oder eine Tabelle wird jedoch die Fehlermeldung angezeigt: „Die Verbindung zur Datenquelle ‚xxx‘ konnte nicht hergestellt werden. / Die Verbindung zur externen Datenquelle konnte nicht hergestellt werden. Es wurde kein SDBC-Treiber für die URL ‚sdbc:embedded:hsqldb‘ gefunden.“

Was habe ich falsch gemacht? Wie kann ich das ändern (experimentieren im Einstellungen-Pfad "LibreOffice Base/Verbindungen" hat nichts gebracht).

Danke, Ruebezahl



swolf
Beiträge: 1135
Registriert: Di 14. Feb 2012, 16:56

Re: ODBCDriver-Problem

Beitrag von swolf » Mo 23. Mär 2015, 18:12

Hallo,

ich habe die Suchfunktion des Forum openoffice.info genutzt ("kein SDBC-Treiber für die URL")
Hilft dir das Ergebnis?
http://de.openoffice.info/search.php?ke ... bmit=Suche
Das älteste und meist besuchte Forum für OpenOffice UND LibreOffice
http://de.openoffice.info
ohne: Adsense, Werbung, Spam o.ä.

ruebezahl
Beiträge: 3
Registriert: Di 2. Dez 2014, 16:49

Re: ODBCDriver-Problem

Beitrag von ruebezahl » Di 24. Mär 2015, 05:20

Hallo swolf,

die Reaktion kam schneller, als ich erwarten konnte, danke. Jetzt muss ich mich erst einmal durch die von Dir genannten links wühlen. Tröstlich ist, dass gleich der erste link (Schriftwechsel zwischen a-zeller und und RobertG genau mein Problem behandelt - und löst. Nur leider ist a-zeller Ubuntu-Nutzer und die Lösung ist für mich als Macuser nicht nutzbar. Ich werde weiterforschen.

ruebezahl

ruebezahl
Beiträge: 3
Registriert: Di 2. Dez 2014, 16:49

Re: ODBCDriver-Problem gelöst

Beitrag von ruebezahl » So 29. Mär 2015, 04:51

Mein ODBCDriver-Problem ist - im Ergebnis - gelöst.

Vorweg eine Korrektur zu meiner Problemmeldung: ursprünglich auf meinem iMac hatte ich LibreOffice 4.2.8.5 installiert (die Datenbank funktionierte; vielleicht spielte die Version von LO eine Rolle bei dem Problem).

Bei weiterem Ausprobieren auf dem MacBook Pro stellte ich unter LO-Einstellungen/erweitert fest, dass als JRE die Version Oracle 1.8.0_40 installiert und aktiviert war. Trotzdem erhielt ich beim Versuch, in meiner eingebetteten Datenbank Formulare oder Tabellen zu öffnen, die Aufforderung eine JRE zu installieren. Ich habe daraufhin zusätzlich Java Apple 1.6._65 von der Apple Supportseite installiert und in den LO-Einstellungen/erweitert aktiviert (meine Datenbank wurde unter Mac OS Lion konzipiert). Seither funktioniert meine Datenbank wieder einwandfrei.

ruebezahl



Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast