Mit Wenn-Bedingung Zeit errechnen

Informationen zur "Libreoffice-forum.de"
Antworten
Bonsai
Beiträge: 10
Registriert: Mi 3. Aug 2016, 12:40

Mit Wenn-Bedingung Zeit errechnen

Beitrag von Bonsai » Mi 23. Jan 2019, 15:42

Hallo Leute,
in LO Calc habe ich Zeiten erfasst z.B.:
Spalte A1: 08:00
Spalte A2: 17:00
Spalte A3: Die Differenz aus beiden
Spalte A4: Hier will ich Pausenzeiten berücksichtigen und zwar, wenn die Differenz größer oder gleich 9:00 Std. ist, dann soll 00:45 erscheinen, wenn nicht soll 00:30 eingetragen werden.
Ich habe es mit der Wenn-Funktion probiert, erhalte aber immer Fehler 502.
Kann mir jemand vllt. einen Tip geben, was ich da falsch mache?

Meine Abfrage lautete in A4:
=Wenn(A3>=9:00;00:45;00:30)

Vielen Dank im Voraus
Bonsai



Benutzeravatar
miesepeter
Beiträge: 975
Registriert: So 19. Dez 2010, 18:16
Wohnort: Bayern

Re: Mit Wenn-Bedingung Zeit errechnen

Beitrag von miesepeter » Mi 23. Jan 2019, 17:01

Hallo, das könnte sowas wie dieses sein:

Code: Alles auswählen

=WENN(A3>=0,375;0,031;0,021)
Uhrzeiten in Dezimalzahlen anzeigen lassen, Ausgabe in der Zelle mit Zeitformat ergibt dann sowas wie 00:44 oder 00:45 etc. (Rundung beachten).
Ciao

Bonsai
Beiträge: 10
Registriert: Mi 3. Aug 2016, 12:40

Re: Mit Wenn-Bedingung Zeit errechnen

Beitrag von Bonsai » Mi 23. Jan 2019, 23:43

@miesepeter
Vielen Dank für deinen guten Tip, es hat gut geklappt.
Allerdings habe ich mit der Rundung noch meine Probleme, in der Spalte A5 soll dann die Zeit abzüglich der Pause erscheinen.
Die Pause ist richtig angezeigt, in der letzten Spalte steht dann aber z.B. 8:14 anstatt 8:15.
Ich dachte daran evtl. einzugeben: Runde auf die nächst höhere ganze Zahl.
In der Hilfe habe ich aber nichts gefunden.
Salut

Bonsai
Beiträge: 10
Registriert: Mi 3. Aug 2016, 12:40

Re: Mit Wenn-Bedingung Zeit errechnen

Beitrag von Bonsai » Do 24. Jan 2019, 00:03

Ich habe den Fehler gefunden, jetzt klappt es prima, nochmals vielen Dank!
Salut



Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast