[gelöst] Hilfe zu SUMMENPRODUKT gesucht

CALC ist die Tabellenkalkulation, die Sie immer wollten.
Antworten
Benutzeravatar
OttoZ
Beiträge: 321
Registriert: Sa 3. Mär 2012, 13:24

[gelöst] Hilfe zu SUMMENPRODUKT gesucht

Beitrag von OttoZ » Mi 9. Mai 2018, 10:11

Libreoffice Version: 6.0.3.2 unter LinuxMint18.3mate64
In meinem Haushaltsbuch nutze ich die AfA. So behalte ich den Überblick, wenn mal dicke Ausgaben für Jahresrechnungen kommen.

Rechnerisch ist das ja kein Kunststück, aber … wenn ich das in einer Matrix unterbringen möchte, verliere ich sicherlich einen Monat meines Lebens.

Daher meine große Bitte, könnte mir das jemand als SUMMENPRODUKT formulieren?
Bin ich unverschämt?

Meine bisherige Lösung war zu umständlich und funktioniert mit dem Umfang von über 5.000 Ausgaben nicht mehr sauber.
Zuletzt geändert von OttoZ am Fr 11. Mai 2018, 10:56, insgesamt 3-mal geändert.
glücklich mit LinuxMintmate64 - & LibreOffice



Lupo
Beiträge: 154
Registriert: Do 11. Okt 2012, 14:22

Re: Hilfe zu SUMMENPRODUKT gesucht

Beitrag von Lupo » Mi 9. Mai 2018, 11:05

Da gehört meine MAX(;MIN-MAX)-Intervallisierung hin:

G1: 1.2.18 statt Febr, (genauso weitere Monate)

G4: =MIN(MAX(0;MIN(G$1+32-TAG(G$1+31);$D4+1)-MAX(G$1;$A4))/$C4;1)*$B4

Du tust Dir einen großen Gefallen, nicht doppelspaltig zu arbeiten (damit meine ich nicht nur die verbundene Zelle). Allein schon zum Formel- und Format-Kopieren. Außerdem werden Dateien grundsätzlich größer, wenn nicht gleiches nebeneinander steht.

Wo soll das SUMMENPRODUKT denn hin? Soll es die Einzelbeträge wie G4 für ganz G:G ausgeben? Ergibt grad keinen Sinn, weil Du die Einzelbeträge ja nun mal hast.
MfG Lupo - xxcl.de Win10ProLO6021

Benutzeravatar
OttoZ
Beiträge: 321
Registriert: Sa 3. Mär 2012, 13:24

Re: Hilfe zu SUMMENPRODUKT gesucht

Beitrag von OttoZ » Mi 9. Mai 2018, 12:37

... ich hatte es mir schwieriger vorgestellt.
Anliegend das Haushaltsbuch mit AfA
Dateianhänge
Kasse_OK.ods
(35.32 KiB) 6-mal heruntergeladen
glücklich mit LinuxMintmate64 - & LibreOffice

Benutzeravatar
OttoZ
Beiträge: 321
Registriert: Sa 3. Mär 2012, 13:24

Re: [gelöst] Hilfe zu SUMMENPRODUKT gesucht

Beitrag von OttoZ » Fr 11. Mai 2018, 11:00

des Rätsels Lösung:
= WENN(MONAT(A5)=MONAT(A4);"";SUMMENPRODUKT(( WENN(D$4:D4 < A4-TAG(A4)+1 ;0; WENN( D$4:D4> MONATSENDE(A4;0) ; MONATSENDE(A4;0) ; D$4:D4) - WENN(A$4:A4 < A4 - TAG(A4) ; A4 - TAG(A4) +1 ; A$4:A4) +1)) * B$4:B4 / C$4:C4))
glücklich mit LinuxMintmate64 - & LibreOffice

Lupo
Beiträge: 154
Registriert: Do 11. Okt 2012, 14:22

Re: [gelöst] Hilfe zu SUMMENPRODUKT gesucht

Beitrag von Lupo » Mo 14. Mai 2018, 21:23

Im gelb unterlegten Feld gibst Du den Jahresbeginn des auszuwertenden Jahres ein.

Wichtig: "Buchungssätze" der angrenzend überlappenden Zeiträume müssen genauso enthalten sein, wie die Grenzen zum Auswertungszeitraum. Um jederzeit global abstimmen zu können.

Es können hier auch gleich einzelne Konten ausgewertet werden (hier jedoch nicht in Vorbereitung für Pivot; müsste also zuerst für Pivot umgestellt werden).

Die Matrixformel SUMME iVm WENN funktioniert in Excel und LO gleichermaßen; SUMMENPRODUKT kann in Excel nicht mit WENN.

Auf RUNDEN habe ich verzichtet.

Ich verwende grundsätzlich DATEDIF-fähige Datumszeiträume, also nicht 1.1.18-31.12.18, sondern 1.1.18-1.1.19 als ein Jahr. Das kann man aber natürlich ändern. Anmerkung: DATEDIF wird nicht verwendet.

I2: {=SUMME($E$2:$E$5/$C$2:$C$5*(I$1=$F$2:$F$5)*WENN(
WENN($D$2:$D$5>$H3;$H3;$D$2:$D$5)-WENN($B$2:$B$5<$H2;$H2;$B$2:$B$5)>0;
WENN($D$2:$D$5>$H3;$H3;$D$2:$D$5)-WENN($B$2:$B$5<$H2;$H2;$B$2:$B$5);))
}
geht kürzer (in neueren Programmversionen LO>4.2, Excel>=2007) auch so:
I2: {=SUMME($E$2:$E$5/$C$2:$C$5*(I$1=$F$2:$F$5)*WENNFEHLER(EXP(LN(
WENN($D$2:$D$5>$H3;$H3;$D$2:$D$5)-WENN($B$2:$B$5<$H2;$H2;$B$2:$B$5)));))
}
--- ich bin aber zur Zeit auf dem Trip maximaler Kompatibilität ---

Die Datei kann entsprechend auch als .ODS gespeichert werden (getestet: 5,2 KB).
180514 Aufwandsverteilung aehnlich AfA.xlsx
(10.81 KiB) 9-mal heruntergeladen
MfG Lupo - xxcl.de Win10ProLO6021



Antworten

Wer ist online?

Mitglieder in diesem Forum: Bing [Bot] und 3 Gäste