Keine Werbeeinblendungen für registrierte User

❤ SPENDEN Sie jetzt für das ❤
🙏 LibreOffice Forum 🙏



  🌹 Danke für Ihre Unterstützung 🌹


Name, Beruf, Firma untereinander > in 3 Spalten bringen

CALC ist die Tabellenkalkulation, die Sie immer wollten.
Antworten
sandsonne
Beiträge: 19
Registriert: Mo 13. Sep 2021, 14:03

Name, Beruf, Firma untereinander > in 3 Spalten bringen

Beitrag von sandsonne » Fr 5. Aug 2022, 16:42

Liebe Forengemeinde,
das für mich Wichtigste zuerst:

1. Dank allen Antworterinnen & Antwortern höchst hilfreich & vorsorglich
2. Ich bin nicht sehr versiert d.h. Macros und großartig Formelbezüge für mich eher :?

Daher weiß ich, was ich für einen vllt. hohen Anspruch auf Hilfe ich hier stelle..... aber evtl. erbarmt sich jemand und zeigt Verständnis und entsprechende Hilfbereitschaft.

Zum Besseren Verständnis habe ich alles in der beigefügten Tabelle vorbereitet: Name, Firma, Beruf habe ich aktuell alles in einer Spalte untereinander, möchte es gerne in separate Spalten nebeneinander.

Wenn ich in Zelle 'B' =A2 mache, klappt das noch, ziehe ich dann runter, war es das... ich weiß nicht wie ich dem Programm sagen soll, was es machen soll...

Nochmals allerbesten Dank, sowohl für Hilfe als auch für Verständnis.
Dateianhänge
Beispieltabelle.ods
(10.53 KiB) 24-mal heruntergeladen

HeritzP
Beiträge: 759
Registriert: Mo 9. Dez 2013, 19:08

Re: Name, Beruf, Firma untereinander > in 3 Spalten bringen

Beitrag von HeritzP » Fr 5. Aug 2022, 17:21

Hallo,

Code: Alles auswählen

=WENNFEHLER(INDEX($A$2:$A$9;(ZEILE(A1)*3-3)+SPALTE(A1));"")
Nach rechts und unten ziehen.
HeritzP

alles nur geklaut

sandsonne
Beiträge: 19
Registriert: Mo 13. Sep 2021, 14:03

Re: Name, Beruf, Firma untereinander > in 3 Spalten bringen

Beitrag von sandsonne » Fr 5. Aug 2022, 19:00

HeritzP hat geschrieben:
Fr 5. Aug 2022, 17:21
Hallo,

Code: Alles auswählen

=WENNFEHLER(INDEX($A$2:$A$9;(ZEILE(A1)*3-3)+SPALTE(A1));"")
Nach rechts und unten ziehen.
"Top" Vielen Dank. Das probiere ich morgen direkt aus. Wenn ich noch Fragen haben sollte, erlaube ich mir, mich nochmals zu melden.

Danke nochmals und für heute einen angenehmen Abend.

Benutzeravatar
karolus
Beiträge: 1662
Registriert: Fr 10. Dez 2010, 10:01

Re: Name, Beruf, Firma untereinander > in 3 Spalten bringen

Beitrag von karolus » Sa 6. Aug 2022, 06:29

Hallo

Code: Alles auswählen

=MTRANS(VERSCHIEBUNG($A$2;ZEILE(A1)*3-3;0;3;1))
mit <strg><shift><enter> bestätigen … oder per [x]Matrix -option im Formelassistenten, und bei gedrückter <strg>taste nach unten ziehen.

oder auch:

Code: Alles auswählen

=MTRANS(INDEX($A$2:$A$1000;ZEILE(A1)*3-2):INDEX($A$2:$A$1000;ZEILE(A1)*3))
LO6.1 Rasbian OS (on ARMHF)

sandsonne
Beiträge: 19
Registriert: Mo 13. Sep 2021, 14:03

Re: Name, Beruf, Firma untereinander > in 3 Spalten bringen

Beitrag von sandsonne » So 7. Aug 2022, 11:58

karolus hat geschrieben:
Sa 6. Aug 2022, 06:29
Hallo

Code: Alles auswählen

=MTRANS(VERSCHIEBUNG($A$2;ZEILE(A1)*3-3;0;3;1))
mit <strg><shift><enter> bestätigen … oder per [x]Matrix -option im Formelassistenten, und bei gedrückter <strg>taste nach unten ziehen.

oder auch:

Code: Alles auswählen

=MTRANS(INDEX($A$2:$A$1000;ZEILE(A1)*3-2):INDEX($A$2:$A$1000;ZEILE(A1)*3))
Zuvor vielen Dank... Leider bin ich bei "[x]Matrix -option" raus - wie eingangs beschrieben, bin ich nicht versiert genug.

Mondblatt24
Beiträge: 2286
Registriert: Fr 3. Mär 2017, 17:12

Re: Name, Beruf, Firma untereinander > in 3 Spalten bringen

Beitrag von Mondblatt24 » So 7. Aug 2022, 12:27

sandsonne hat geschrieben:
So 7. Aug 2022, 11:58
Leider bin ich bei "[x]Matrix -option" raus
2022-08-07 12 26 08.png
2022-08-07 12 26 08.png (66.88 KiB) 122 mal betrachtet
Win 11 (x64) ▪ LO 7.3.5.2 (x64) ▪ AOO Portable 4.1.12
Wenn Eure Frage zutreffend beantwortet wurde, seid so nett und fügt dem Betreff der Eingangsfrage [GELÖST] hinzu.

sandsonne
Beiträge: 19
Registriert: Mo 13. Sep 2021, 14:03

Re: Name, Beruf, Firma untereinander > in 3 Spalten bringen

Beitrag von sandsonne » Mo 8. Aug 2022, 11:38

HeritzP hat geschrieben:
Fr 5. Aug 2022, 17:21
Hallo,

Code: Alles auswählen

=WENNFEHLER(INDEX($A$2:$A$9;(ZEILE(A1)*3-3)+SPALTE(A1));"")
Nach rechts und unten ziehen.
Entschuldigung das ich nochmals störe:

Bei 5579 Zeilen insgesamt muss ich die Formel ändern wie folgt oder?

=WENNFEHLER(INDEX($A$2:$A$5579;(ZEILE(A1)*3-3)+SPALTE(A1));"")

oder muss ich noch eine andere Änderung vornehmen?

Vielen Dank und entschuldigung.

HeritzP
Beiträge: 759
Registriert: Mo 9. Dez 2013, 19:08

Re: Name, Beruf, Firma untereinander > in 3 Spalten bringen

Beitrag von HeritzP » Mo 8. Aug 2022, 11:49

Hallo,

sollte passen, einfach testen.
HeritzP

alles nur geklaut

sandsonne
Beiträge: 19
Registriert: Mo 13. Sep 2021, 14:03

Re: Name, Beruf, Firma untereinander > in 3 Spalten bringen

Beitrag von sandsonne » Mo 8. Aug 2022, 13:48

HeritzP hat geschrieben:
Mo 8. Aug 2022, 11:49
Hallo,

sollte passen, einfach testen.
Es hat funktioniert. Danke nochmals.

Antworten