Keine Werbeeinblendungen für registrierte User

❤ SPENDEN Sie jetzt für das ❤
🙏 LibreOffice Forum 🙏



  🌹 Danke für Ihre Unterstützung 🌹


SVERWEIS funktioniert nicht mit einem + im Suchkriterium

CALC ist die Tabellenkalkulation, die Sie immer wollten.
Antworten
MAWSpitau
Beiträge: 5
Registriert: Do 26. Mai 2011, 20:37

SVERWEIS funktioniert nicht mit einem + im Suchkriterium

Beitrag von MAWSpitau » Di 16. Aug 2011, 19:55

Moinsen.

Ich habe eine Tabelle erstellt, um Noten für Schülerinnen und Schüler berechnen zu lassen. Da ich an einer Beruflichen Schule arbeite, muss ich mit dem IHK Schlüssel rechnen.

Ich habe eine Tabelle in der in der ersten Spalte Noten stehen und in der zweiten Spalte soll der entsprechende Prozentwert ausgegeben werden. Dieser Prozentwert ist auf einer anderen Tabelle in einer Matrix verankert.

Alle Zahlen werden korrekt umgerechnet, bis auf die, die ein Plus haben. Sprich: 1 wird korrekt berechnet, 1- auch, aber 1+ erhält den Wert von 1. Das ist nicht richtig. Setze ich in der Matrix und in der Tabelle eine andere, frei gewählte Zeichenkombination, funktioniert die Umrechnung wieder. Es scheint also "irgendwie" an dem Plus zu liegen

Zur Verdeutlichung ein paar Screenshots.

Die Matrix
Bild

Die Tabelle
Bild

Der Verweis

Code: Alles auswählen

=WENN(B25="";"";SVERWEIS(B25;$Umrechnung.$AF$1:$AG$101;2;0))
Ich freue mich über jeden Lösungsansatz.

Vielen Dank
MAWSpitau

paljass
Beiträge: 623
Registriert: Fr 18. Mär 2011, 15:34

Re: SVERWEIS funktioniert nicht mit einem + im Suchkriterium

Beitrag von paljass » Mi 17. Aug 2011, 06:32

Moin,
ja, ja, SVerweis und Sonderzeichen... zwei Welten stoßen aufeinander, allerdings auch nicht immer.

Ich unter Oo folgende Formel getestet und für gut befunden:

Code: Alles auswählen

=INDIREKT("B"&MAX((ZEILE(A1:A1000)*(A1:A1000=D1))))
Diese Formel musst du mit Stg-Umschalt-Enter als Matrixformel abschließen; sie sollte auch unter LO funktionieren.

Noch kurz zur Erklärung:
In Spalten A und B steht das, was du in deiner Frage als "Die Matrix" bezeichnest in Zelle D1 der Wert, der in Spalte A gesucht wird.

Die Formel kannst du übrigens nicht runterziehen, du musst sie kopieren und einfügen, wobei das Einfügen auch in mehrere Zellen gleichzeitig geht.

Viel Erfolg
paljass

Antworten