Update auf LO 4.2.4.2: Formeln werden falsch angezeigt

Math ist die Komponente von LibreOffice für die Erstellung von mathematischen Gleichungen.
Antworten
Uli Gebhardt
Beiträge: 2
Registriert: Mo 12. Mai 2014, 10:27

Update auf LO 4.2.4.2: Formeln werden falsch angezeigt

Beitrag von Uli Gebhardt » Mo 12. Mai 2014, 10:34

Seit einem Update auf LibreOffice 4.2.4.2 werden bei mir die Formeln falsch angezeigt. Zeichen wie Klammern, Gleichheitszeichen, Operatoren wir + und - etc... werden offenbar in der Schriftart Windings o.ä. angezeigt. So wird z.B. das Gleichheitszeichen Diskette und das + als Briefumschlag dargestellt.
Ich habe versucht, das über Format -> Schriftarten zu ändern, aber es funktioniert nicht.
Ist das ein Bug? Gibt es da schon einen Workaround oder eine Korrektur?

Edit: System ist übrigens Windows 8.1, 64 Bit. Ich arbeite jetzt zur Überbrückung mit einer alten Version von LibreOffice auf einer Linux LiveDVD.



Benutzeravatar
lorbass
Beiträge: 627
Registriert: Mo 25. Apr 2011, 18:17

Re: Update auf LO 4.2.4.2: Formeln werden falsch angezeigt

Beitrag von lorbass » Mo 12. Mai 2014, 15:34

Ein Versuch ins Blaue, da ich eine ältere LO-Version unter GNU/Linux benutze und daher das Verhalten nicht nachstellen kann:

LibreOffice „bedient“ sich aus den Fonts, die es (1.) im Fonts-Verzeichnis des Betriebssystems, (2.) im LibreOffice-InstallationsVerzeichnis* oder (3.) im BenutzerVerzeichnis* findet. Normalerweise wird der Font opens___.ttf im LibreOffice-Installationsverzeichnis unter …\share\fonts\truetype\ installiert. Wenn der in deiner 4.2.4.2-Installation fehlt, kopiere ihn aus deiner älteren Installation in die neue oder ins Benutzerverzeichnis und versuch's dann damit nochmal.

* Die Links sind zwar alt und kennen Windows 8 nicht, helfen aber zumindest mit der Beschreibung des Aufbaus der Verzeichnisse. Das Installationsverzeichnis unter Windows ist C:\Programme\LibreOffice4.2 oder so ähnlich…

Gruß
lorbass

Uli Gebhardt
Beiträge: 2
Registriert: Mo 12. Mai 2014, 10:27

Re: Update auf LO 4.2.4.2: Formeln werden falsch angezeigt

Beitrag von Uli Gebhardt » Mi 14. Mai 2014, 08:46

Das Verzeichnis \fonts existiert weder im Installationsverzeichnis unter \share noch im Benutzerverzeichnis (wobei letzteres unter Win 8 echt schwer zu finden war).

Ich denke, ich werde Libreoffice 4.2.4 deinstallieren und die Version 4.2.3 weiter nutzen. Ich hoffe, dass Ende des Monats Linux Mint 17 veröffentlicht wird; das kommt auf meinen neuen PC und dann wird wahrscheinlich wieder alles seinen normalen Gang gehen.
Danke jedenfalls für die Mühe.

triefnase
Beiträge: 2
Registriert: Di 2. Sep 2014, 20:37

Re: Update auf LO 4.2.4.2: Formeln werden falsch angezeigt

Beitrag von triefnase » Di 2. Sep 2014, 20:47

Hallo zusammen,

auch bei mir tritt das beschriebene Problem seit einiger Ziet auf, dummerweise in unterschiedlichsten Spielarten. Um es genauer zu beschreiben, habe ich mal zwei Screenshots hochgeladen, auf denen zu erkennen ist, dass insbesondere die Sonderzeichen trotz richtiger Sysntax nixht erkannt werden, obwohl sie dem Katalog richtig zugeordnet wurden (1. Bild).

Die Konfiguration ist hier "windows 8" i.V. mit LO 4.2.1.1 !!!
Auf meinem Acer-Laptop mit "windows 8.1" sieht es so aus, wie von Euch vorab beschrieben. DEr Editor ist für so so leider nicht mehr nutzbar.

Ich habe versucht, die Dateien (math.xcd) durch ältere zu ersetzen, ohne Änderung. Ich habe schon viele Einstellungen mit denen einer funktionierenden Version verglichen, ohne Erfolg.

Es wäre sehr schön, wenn da jemand einen helfenden Tipp geben könnte. Danke und Gruß

Dirk die Triefnase (vielleicht ist ja der Name Programm ...)

Erg.: Ich weiß, im unteren Bild fehlt das Prozent-Zeichen vor der Bezeichnung (%Ux2225), geht aber auch dann wirklich nicht, s. 1. Bild
Dateianhänge
LO-Math-Katalog-Font-erg.jpg
Ergänzung zu Bild 2 mit dem Hinweis, dass das fehlende Zeichen dem Katalog ordnungsgemäß zugeordnet wurde.
LO-Math-Katalog-Font-erg.jpg (84.02 KiB) 5145 mal betrachtet
LO-Math-Katalog-Font.jpg
Beispiel für eine "Formel" mit einigen Zeichen die funktionieren und dem nicht (mehr) funktionierenden Sonderzeichen
LO-Math-Katalog-Font.jpg (122.45 KiB) 5145 mal betrachtet



Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast