(gelöst) LO nicht öffenbar wg. wiederherstellungsmenü

Komponentenübergreifende Themen zu Libreoffice
Antworten
michaa7
Beiträge: 79
Registriert: Do 27. Okt 2011, 16:12

(gelöst) LO nicht öffenbar wg. wiederherstellungsmenü

Beitrag von michaa7 » Fr 13. Jul 2018, 12:16

LO, Debian/SID linux , LO 6.0.6 (selbes problem auch mit vorgängerversion)

Hi, ich habe hier jetzt eine Endlosschleife die dazu führt dass ich kein LO Dokument öffen/bearbeiten/drucken kann, weil zunächst die Wiederhestellungskonsole sich öffnet und egal ob ich verwerfe oder abbreche oder sonstwas tue sich LO nicht öffnet, auch wenn die wiederherstellungskonsole geleert wurde. Das ist echt nerfig, dass dieser punkt nicht wirklich überspringbar ist, denn jetzt bin ich ausgeschlossen bis mir jemand erklärt wie ich das löse.

:(

MH
Zuletzt geändert von michaa7 am Sa 14. Jul 2018, 15:39, insgesamt 1-mal geändert.



nikki
Beiträge: 693
Registriert: Sa 18. Mär 2017, 22:25
Kontaktdaten:

Re: LO nicht öffenbar wg. wiederherstellungsmenü

Beitrag von nikki » Fr 13. Jul 2018, 13:12

Dann bliebt Dir nur noch die Möglichkeit das Benutzerprofil zurückzusetzen.
Gruß

------------------------------------------------------------------------------
Win.10 Prof. 64-bit, LO 6.0.7 (x64), LO 5.4.7 Portable, AOO 4.1.6

DavidG
Beiträge: 129
Registriert: Do 22. Mär 2018, 21:41

Re: LO nicht öffenbar wg. wiederherstellungsmenü

Beitrag von DavidG » Fr 13. Jul 2018, 13:46

Hallo,

bevor Du das Benutzerverzeichnis zurücksetzt, suche zuerst nach
Dateien mit der Endung: ~lock und lösche diese.
Diese Dateien sind Überbleibsel, wenn LO mal nicht sauber beendet wurde/ abgestürzt ist, etc.
Diese werden immer beim Öffnen von Dokumenten angelegt und sollten nach dem Schließen der Dokumente
automatisch gelöscht werden. Ist diese nicht der Fall, versucht LO immer die Wiederherstellung der Dateien.


Gruß
David
Gruß

David
___________________
WIN 10 PRO
LO 6.0.4.2 32-Bit

nikki
Beiträge: 693
Registriert: Sa 18. Mär 2017, 22:25
Kontaktdaten:

Re: LO nicht öffenbar wg. wiederherstellungsmenü

Beitrag von nikki » Fr 13. Jul 2018, 17:30

Hallo David,
DavidG hat geschrieben:
Fr 13. Jul 2018, 13:46
Diese werden immer beim Öffnen von Dokumenten angelegt und sollten nach dem Schließen der Dokumente
automatisch gelöscht werden. Ist diese nicht der Fall, versucht LO immer die Wiederherstellung der Dateien.
hier irrst Du. Wiederherstellungsinfos (Differenz zwischen aktuellem Stand und der letzten Speicherung) werden in der Datei registrymodifications.xcu des Benutzerprofils festgehalten.

Bei Lock-Dateien dagegen handelt es sich um einfache Textdateien die lediglich dazu dienen, dass während der Bearbeitung eines Dokuments diese nicht gleichzeitig von einem anderen Benutzer zur Bearbeitung geöffnet werden können. Dass eine Lockdatei noch existiert bekommt LO erst mit, wenn das dazu gehörende Dokument geöffnet werden soll.
Gruß

------------------------------------------------------------------------------
Win.10 Prof. 64-bit, LO 6.0.7 (x64), LO 5.4.7 Portable, AOO 4.1.6

michaa7
Beiträge: 79
Registriert: Do 27. Okt 2011, 16:12

Re: LO nicht öffenbar wg. wiederherstellungsmenü

Beitrag von michaa7 » Sa 14. Jul 2018, 02:28

Und was mache ich jetzt?

Ich kann zwar die wiederherstellungsdaten "verwerfen", das scheint auch zu funktionieren, doch nur für alle dateien bis auf "unbekannt1". Dieses dokument möchte immer wieder hergestellt werden und kann auch nicht verworfen werden -> Ich kann LO nicht öffnen.

nikki
Beiträge: 693
Registriert: Sa 18. Mär 2017, 22:25
Kontaktdaten:

Re: LO nicht öffenbar wg. wiederherstellungsmenü

Beitrag von nikki » Sa 14. Jul 2018, 09:15

nikki hat geschrieben:
Fr 13. Jul 2018, 13:12
Dann bliebt Dir nur noch die Möglichkeit das Benutzerprofil zurückzusetzen.
michaa7 hat geschrieben:
Sa 14. Jul 2018, 02:28
Und was mache ich jetzt?
???
Gruß

------------------------------------------------------------------------------
Win.10 Prof. 64-bit, LO 6.0.7 (x64), LO 5.4.7 Portable, AOO 4.1.6

Hazel
Beiträge: 420
Registriert: Mi 22. Mai 2013, 10:34
Wohnort: Heroldsberg (ERH)

Re: LO nicht öffenbar wg. wiederherstellungsmenü

Beitrag von Hazel » Sa 14. Jul 2018, 10:02

Hallo michaa7

Wenn dir der Vorschlag mit dem Wegräumen und Neuanlegen des Benutzerprofils nicht so ganz geheuer ist, dann lege doch einfach mal einen neuen Benutzer an und starte LO von dort aus. Das neue /home/<user> muss dann doch unbelastet von der Vergangenheit sein. Auf diese Weise kann du sehen, ob LO grundsätzlich beschädigt ist oder die individuellen Benutzereinstellungen dir einen Streich spielen.

Viel Glück
Hazel

nikki
Beiträge: 693
Registriert: Sa 18. Mär 2017, 22:25
Kontaktdaten:

Re: LO nicht öffenbar wg. wiederherstellungsmenü

Beitrag von nikki » Sa 14. Jul 2018, 10:06

Hallo Hazel,
ich denke, dass das Zurücksetzen des Benutzerprofil durch Umbenennung, wie im Linke beschrieben, einfacher wäre.
Gruß

------------------------------------------------------------------------------
Win.10 Prof. 64-bit, LO 6.0.7 (x64), LO 5.4.7 Portable, AOO 4.1.6

michaa7
Beiträge: 79
Registriert: Do 27. Okt 2011, 16:12

Re: LO nicht öffenbar wg. wiederherstellungsmenü

Beitrag von michaa7 » Sa 14. Jul 2018, 15:27

Mit einem neuen, leeren nutzerprofil versuche ich LO zu starten. Da erscheint nichteinmal die wiederherstellungskonsole. LO verabschiedet sich kommentarlos. Durch starten aus einem VT erhalte ich folgende fehlermeldung:
$ libreoffice

(soffice:7187): dbind-WARNING **: 15:19:21.740: Error retrieving accessibility bus address: org.freedesktop.DBus.Error.ServiceUnknown: Th$

(soffice:7187): Gtk-WARNING **: 15:19:21.811: Could not load a pixbuf from icon theme.
This may indicate that pixbuf loaders or the mime database could not be found.
**
Gtk:ERROR:../../../../gtk/gtkiconhelper.c:494:ensure_surface_for_gicon: assertion failed (error == NULL): Failed to load /usr/share/icons$
Application Error

michaa7
Beiträge: 79
Registriert: Do 27. Okt 2011, 16:12

Re: LO nicht öffenbar wg. wiederherstellungsmenü

Beitrag von michaa7 » Sa 14. Jul 2018, 15:38

Problem gelöst. Dies gtk-pixbuf problem hat für die probleme (nicht nur mit LO) gesorgt. Ein

Code: Alles auswählen

/usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/gdk-pixbuf-query-loaders > /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache
hat dies nun wieder gerichtet. Ich konnte anschließend die wiederherstellung des dokuments "unbekannt1" verwerfen und LO startet.

Danke an alle.



Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast