Zählenwenn, Anzahl, Summenprodukt?

CALC ist die Tabellenkalkulation, die Sie immer wollten.
Antworten
hylli
Beiträge: 213
Registriert: Sa 19. Mär 2011, 19:00

Zählenwenn, Anzahl, Summenprodukt?

Beitrag von hylli » Mi 17. Apr 2019, 16:33

In anhängender Datei will ich per Formel in Spalte C ermitteln, ob in einer Einheit(ennummer) in Spalte A mindestens eins oder mehrere Segmente in Spalte B zwischen 200-300 vorkommt/en oder nicht.

Wenn ja, soll in Spalte C eine 1 stehen, ansonsten eine 0.

Damit möchte ich im Anschluss filtern nur die Einheiten Filtern, bei denen das zutrifft (per Pivot, da noch mehr Spalten im Original!)

Stehe gerade mal wieder auf'm Schlauch, und bekomme das gerade nicht hin?

Hylli
Dateianhänge
Segmente_in_Einheiten.ods
(46.57 KiB) 25-mal heruntergeladen
Geschäftlich: LibreOffice 5.4.0.3 unter Windows 10 64bit
Privat: LibreOffice 6.0.x unter Linux Mint 18.3 Cinnamon 64bit

Mondblatt24
Beiträge: 822
Registriert: Fr 3. Mär 2017, 17:12

Re: Zählenwenn, Anzahl, Summenprodukt?

Beitrag von Mondblatt24 » Mi 17. Apr 2019, 16:54

Hallo,
C2=

Code: Alles auswählen

=ZÄHLENWENNS(B2;">200";B2;"<300")
oder

Code: Alles auswählen

=N(UND(B2>200;B2<300))
und nach unten kopieren.

Gruß Peter
Win.10 (x64)__ LO 6.2.5 (x64); AOO Portable 4.1.5
Fragen, die zur Zufriedenheit beantwortet wurden, sollten im Betreff des Eröffnungspost mit dem Zusatz [GELÖST] versehen werden.

hylli
Beiträge: 213
Registriert: Sa 19. Mär 2011, 19:00

Re: Zählenwenn, Anzahl, Summenprodukt?

Beitrag von hylli » Mi 17. Apr 2019, 17:39

Trifft es nicht ganz, denn es besteht hier keine Abhängigkeit zur Einheit in Spalte A.

Hier vielleicht ein besseres Beispiel, mit dem Ergebnis das ich in Spalte D erwarte.

Hylli
Dateianhänge
Segmente_in_Einheiten_Bsp_2.ods
(12.68 KiB) 28-mal heruntergeladen
Geschäftlich: LibreOffice 5.4.0.3 unter Windows 10 64bit
Privat: LibreOffice 6.0.x unter Linux Mint 18.3 Cinnamon 64bit

HeritzP
Beiträge: 441
Registriert: Mo 9. Dez 2013, 19:08

Re: Zählenwenn, Anzahl, Summenprodukt?

Beitrag von HeritzP » Do 18. Apr 2019, 16:59

Hallo,

mit Hilfsspalte und zus. Pivot Tabelle.
Segmente_in_Einheiten_Bsp_2.ods
(12.75 KiB) 26-mal heruntergeladen
und mit Formel anstatt Pivot Tabelle.
Segmente_in_Einheiten_Bsp_3.ods
(14.03 KiB) 26-mal heruntergeladen
Gruß HeritzP

Antworten