Formel mit Bezüge erstellen

CALC ist die Tabellenkalkulation, die Sie immer wollten.
Antworten
dominik
Beiträge: 8
Registriert: Sa 11. Aug 2018, 13:15

Formel mit Bezüge erstellen

Beitrag von dominik » Sa 11. Aug 2018, 13:34

Hallo!

Ich muss für folgende Angabe eine Formel erstellen und komme leider nicht weiter, wär echt super wenn mir jemand weiterhelfen könnte!
Ausgaben

Das ist die Tabelle mit der Angabe:

D E F
Zweck Preis bezahlt von
pool -10,00 JPY Jim
gas 1 -30,81 JPY Jim
gas 2 -22,61 JPY Markus
hotel -193,88 JPY Japaner 1
parking -15,00 JPY Samuel
car rental -204,23 JPY Japaner 2
bus -350,00 JPY Jim
train -75,00 JPY Jim
gas 3 -27,85 JPY Jim
tickets -120,00 JPY Jim


Und diese Tabelle muss ich mit Werten befüllen:
A B C D E F G H I
Kostenteilung Jim Markus Japaner1 Japaner2 Samuel Lukas Lisa Dominik
pool
gas 1
gas 2
hotel
parking
car rental
bus
train
gas 3
tickets

Die Angabe ist:
In der Tabelle müssen Sie jetzt nur noch mithilfe einer passenden Formel
die Kosten einer Person berechnen. Dabei ist folgendes zu beachten (x…Anzahl Teilnehmer):
• Derjenige oder diejenige, der/die den Posten bezahlt hat, erhält hierfür den (x-1)/x
Bruchteil der Kosten gutgeschrieben (positiver Betrag!!!). Alle anderen müssen 1/x
der Kosten zahlen (negativer Betrag)
• Die Formel soll mit Bezügen arbeiten, sodass Sie problemlos über die 10x8 Felder
gezogen werden kann. In jeder Spalte soll abschließend eine Summe sein, welche
die Kosten bzw. die Rückvergütung einer Person festhält.
• Da Rundungsfehler hier unter Umständen zu Problemen führen können, runden Sie
alles auf 2 Kommastellen auf.
• Sollten weniger als 8 Personen bzw. 10 Rechnungen angegeben werden, kann es
unter Umständen sein, dass kein Wert (NV#) angezeigt wird. Passen Sie die Formel
so an, dass dies nicht geschieht.
• Sorgen Sie außerdem dafür, dass keine 0-Einträge angezeigt werden. Stattdessen
soll die Zelle in diesem Fall leer bleiben

Ich komme einfach nicht auf eine Formel!!
Aktuell komme ich nur auf =WENN(SVERWEIS(D4;$D$4:$F$13;3)=$B$16;($B$3-1)/$B$3*-E4;(1/$B$3*E4))

Wär echt cool wenn mir da jemand weiterhelfen könnte, da ich schon zwei Stunden probiere und einfach nicht auf das richtige Ergebnis komme!

Vielen Dank im Voraus
Dominik



HeritzP
Beiträge: 339
Registriert: Mo 9. Dez 2013, 19:08

Re: Formel mit Bezüge erstellen

Beitrag von HeritzP » Sa 11. Aug 2018, 18:08

Hallo,

eine Beispieldatei mit den erwarteten Werten würde helfen.


Gruß HeritzP

dominik
Beiträge: 8
Registriert: Sa 11. Aug 2018, 13:15

Re: Formel mit Bezüge erstellen

Beitrag von dominik » Sa 11. Aug 2018, 18:16

18SS-248705-D2-Maxwald-Study-Abroad.ods
(43.2 KiB) 20-mal heruntergeladen

HeritzP
Beiträge: 339
Registriert: Mo 9. Dez 2013, 19:08

Re: Formel mit Bezüge erstellen

Beitrag von HeritzP » Sa 11. Aug 2018, 19:58

Hallo,

so evtl.
18SS-248705-D2-Maxwald-Study-Abroad.ods
(33.28 KiB) 22-mal heruntergeladen
Unter Extras -> Optionen -> LibreOffice Calc -> Berechnen muss die Iteration eingeschaltet sein.

Gruß HeritzP

HeritzP
Beiträge: 339
Registriert: Mo 9. Dez 2013, 19:08

Re: Formel mit Bezüge erstellen

Beitrag von HeritzP » So 12. Aug 2018, 09:26

Hallo,

ohne Iteration und anstatt MAX() eine SVERWEIS() Formel.
18SS-248705-D2-Maxwald-Study-Abroad_SVERWEIS.ods
(34.06 KiB) 21-mal heruntergeladen
18SS-248705-D2-Maxwald-Study-Abroad_SVERWEIS_2.ods
mit Matrixformel
(33.23 KiB) 19-mal heruntergeladen
Gruß HeritzP

dominik
Beiträge: 8
Registriert: Sa 11. Aug 2018, 13:15

Re: Formel mit Bezüge erstellen

Beitrag von dominik » So 12. Aug 2018, 11:17

Hallo!

Echt super vielen Dank für die schnelle Rückmeldung, seits echt die besten :D

LG

mikele
Beiträge: 827
Registriert: Mo 1. Aug 2011, 20:51

Re: Formel mit Bezüge erstellen

Beitrag von mikele » So 12. Aug 2018, 12:36

Hallo,
wenn du in die Zelle B17 die Formel:

Code: Alles auswählen

=WENN($F4=B$16;-$E4*($B$3-1)/$B$3;$E4/$B$3)
setzt und nach rechts und unten ziehst, sollte es auch funktionieren.
Gruß,
mikele



Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 9 Gäste